For Autodesk Revit users who would like to utilize Nearmap 3D as surrounding context for BIM and Revit models, we recommend using the Point Cloud content type linked into Revit. Currently, there is no workflow to import or link 3D textured mesh to Revit. There are, however, alternative workflows to combine Revit models with 3D Textured Mesh and/or Point Cloud but these require other CAD and GIS applications (Autodesk InfraWorks, Esri ArcGIS Pro, and Trimble SketchUp, to name a few). Those integrations will be covered in upcoming posts.


The steps to link Nearmap 3D Point Cloud .las to Revit are outlined below.

  • For Revit 2018, the Point Cloud .las file type may be indexed directly into .rcp format without the need for Autodesk Recap.
  • For Revit 2019, 2020 and later versions, Autodesk Recap is required to create the .rcp file for linking the .las Point Cloud to Revit.





Revit 2018

You may index the .las to .rcp inside of Revit. Go to Insert Tab → Select Point Cloud.

In the Link to Point Cloud window, select the File Type Format .las from the dropdown menu and then the .las file from Nearmap → Open. The Point Cloud Indexing will open → Start Indexing.


Once the index is at 100%, close the window and then go to Insert Tab → Point Cloud. Select .rcp from the Files of Type dropdown. Then select the .rcp file that was created in the previous step → Open.




View the Point Cloud in 3D

Go to the View tab → Select 3D View → Default 3D View.




Revit 2019 and later versions

You need to index the .las to .rcp inside of Autodesk ReCap first. This application will also allow you to clip out areas and remove other artifacts in the Point Cloud. Launch ReCap → Start New Project → Import Point Cloud. Create New Project → Proceed.

Select Files to Import → select .las files from Nearmap → Open → Import Files.

ReCap will index the files, after the process is finished, you may Launch Project.

ReCap has now created the .rcp needed to import into Revit.




Clip out unwanted areas

ReCap also allows you to clip out areas and delete artifacts in the model. Ensure the Window button near the bottom center of the screen is selected and then click and drag mouse around areas you would like to remove. These points will be selected, then you may use Delete on your keyboard to remove. Save the .rcp file to save your edits to the model.




Open the Point Cloud in Revit

Launch the application and go to Insert Tab Link Point Cloud.

Select the .rcp file that was created in ReCap which may include your edits → Open.




View the 3D Point Cloud

Go to View tab → select 3D View.



Unable to render {include} The included page could not be found.