Supported Browser Versions

The Nearmap MapBrowser is supported in the most recent and second most recent versions of Mozilla Firefox, Safari, Microsoft Edge and Google Chrome.  We do not support Internet Explorer 9 and below.

JavaScript needs to be enabled on your web browser.

The requirements for effective use of Nearmap depend on the specific tools you are using.

 In all cases we strongly recommend:

  • Using an up-to-date browser, such as Chrome, Firefox, Safari or Internet Explorer 11. The advanced tools will not work well on older browser versions.
  • A fast, reliable internet connection.

Viewing 3D in MapBrowser

For best results when viewing 3D in MapBrowser use modern browsers that support WebGL (https://get.webgl.org/).

We recommend the latest versions of:

  • Chrome
  • Firefox
  • Safari

Microsoft Edge is not recommended.

IE 11 is not supported.

Internet Explorer 10 and earlier non-compatibility

If you are using Internet Explorer 10 and below, from May 2020 you will not be able to view MapBrowser Classic

Instead you will get an error message saying "You are using a browser that is not supported by the Google Maps JavaScript API. Consider changing your browser".

Please upgrade your browser to Internet Explorer 11, or consider using Google Chrome.

Suggested System Specifications for Basic Browsing

For basic browsing of MapBrowser (including use of measurement tools), we recommend:

  • A PC with at least 2GB of RAM, or
  • A modern smartphone or tablet device, and
  • The latest version of Google Chrome.

Suggested System Specifications for Advanced or Professional Use

If you use Nearmap’s advanced features, such as Data Layers, the Solar Tool, Shadow Modelling, Flood Modelling, Volume Estimation and Site Planner, we recommend using:

  • A PC with at least 8GB of RAM, and
  • The latest version of Chrome.